В Android P не будут работать старые приложения


Приложения, при разработке которых использовалось API под Android 4.1 и ниже, могут больше не поддерживаться новой операционной системой Android P. То есть можно сказать, что старые приложения не будут работать на устройствах под управлением Android P или будут работать некорректно. Информация об этом поступила от участников программы тестирования последней версии ОС Android и имеющих доступ к сборке Android P Deweloper Preview.

В Android P не будут работать старые приложения

При инсталляции такого приложения на новой ОС, пользователь получит предупреждение, что приложение создано для старых версий операционной системы и может работать с ошибкой.

приложение создано для старых версий операционной системы

На сегодня самая нижняя версия API, которую поддерживает Android P – это версия v17, которая соответствует Андроид  4.2. Если в следующих сборках новой ОС такое предупреждение останется, то можно думать, что в будущем Google может убрать из официального магазина приложений старое ПО.

Такое желание выглядит вполне логичным, как способ стимулирования разработчиков обновить свой продукт до совместимости к все более жестким требованиям, предъявляемым Google к программному продукту для Android OS

С этим еще читают:

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *